← All posts tagged блокнотики

vt

в этот блокнот-переросток типа встроили функцию обновления путей импортов во всех файлах, если я переименовал файл. Ну, переименовал файл, жду. Ничего не происходит. Ладно, обновлю руками. Обновил. Где-то через минуту появилось радостное сообщение "о! Хочешь я тебе импорты обновлю?". И это не со сторонним языком, а с джаваскриптом, с которым это чудо типа родное. То есть выбор таков — или терпеть продукты джетбрейнс с их глюками, но которые все делают как надо, или мучаться с этими кастрированными блокнотиками, которые ничего нормально делать не могут вообще!

vt

Коалиция красноглазиков из Microsoft, Redhat и Pivotal совместно выпустили убийцу IDEA — сию убийцу можно запускать на atom и vscode. ОООООООООоооооооочень дооооооолго разбирает проект, нет ладно бы при первом запуске, так ооооочень доооолго перечитывает проект при изменении любой буквы. Даже за зарплату красноглазые долбоебы не могут сделать нормально.

vt

Сегодня день блокнотиков с подсветкой синтаксиса: зарелизился sublime 3 — sublimetext.com — особенный блокнотик, в котором за 80 евро надо настраивать междустрочный интервал, отключать номера строк, табы, курсив и подбирать цветовую схему, чтоб глаза не кровоточили. Ну и в результате не получить ничего, кроме блокнотика. Да, красноглазиков надо доить на бабки, все правильно делают!

vt
· Edited

tuhdo.github.io
На HN пиарится очередная сборочка конфигов для емакса "емакс — это не просто блокнотик с подсветкой синтаксиса!" и как обычно нихрена не работает:
moo-complete-candidates-2: Unexpected [3 times]
moo-ttype->tmembers: Wrong type argument: listp, t
Закопайте уже кто-нибудь этих жалких врунишек.

vt

Очередной раз поражаюсь, как в линуксе все просто и удобно, кукареку, пакетные менеджеры, кудах.
Наслушался про то, что в линуксе щас во всех блокнотиках для редактирования c/c++/objc есть возможность крутого автодополнения с помощью clang. Ну здорово, решил сначала попробовать под вендой, ибо было сказано, что модный блокнотик sublime text умеет работать и в венде. Скачал, поставил package control, поставил SublimeClang, попробовал — нууу, типа работает, только надо руками прописывать пути к заголовкам, которые этот самый libclang будет парсить. Что-то даже прописал, потом устал и забил.
Тут случайно наткнулся на подобный модуль для emacs. Ну emacs мне ближе, раньше пользовался, решил еще покрасноглазить, в итоге руками собрал clang, руками собрал emacs-clang-complete-async. Не работает, падает. Ну ладно, тут начинается самое веселое, решил попробовать тоже самое в линуксе, ведь там все просто и само должно заработать. Нуу, разве что всего лишь emacs-clang-complete-async руками собрать. Ну собрал, это я уже и под вендой делал. Оно даже заработало, ничего больше не настраивая! Только почему-то ВНЕЗАПНО перестало, и в логах емакса тишина. Ну да ладно. Решил попробовать sublime text здесь же. А тут... а тут он не работает. Не ставится на него SublimeClang. Надо собрать руками отдельный петон, через какой-то еще pythonbrew новомодный, подсунуть его отдельно к sublime text, и тогда возможно заработает. Написано баг известный, в принципе в любом линуксе, но чинить никто не собирается. Пиздец какой-то. И так в этом линуксе всё. Не удивлюсь, что еще через пару лет в линуксе и ls начнет глючить.