← All posts tagged Qt

name
Ubuntu Qt otter-browser б-женька, спасибо — у меня наконец-то стал компилиться otter-browser.

История успеха:

1) качаем и устанавливаем отсюда qt-project.org свежайшую линуксовую версию QT для вашей архитектуры.

ВНИМАНИЕ! УБУНТОВЫЕ ПАКЕТЫ qt4-qmake И qt5-qmake НЕ НУЖНЫ ОТ СЛОВА СОВСЕМ.

2) устанавливаем всё необходимое

sudo apt-get update && sudo apt-get install libgstreamer1.0-dev libgstreamer0.10-dev libgstreamer-plugins-base1.0-dev libgstreamer-plugins-base0.10-dev libqt5webkit5-dev

за подсказку спасибо @RA #2703237

3) выполняем что написано здесь

github.com

до команды

qmake ../otter.pro

вместо неё выполняем

/home/user/Qt/5.2.1/gcc/bin/qmake ../otter.pro

или куда вы там поставили себе свежайшую версию QT, а затем уже

make

make install

ВСЁ.
name
Ubuntu Qt otter-browser вjт как писал про Otter browser @RA в #2693622 — нихуя не компилится.

Я сейчас вернулся к этому делу и мне помогло вот что

sudo apt-get purge qt4-qmake

sudo apt-get autoremove

sudo apt-get install qt5-qmake

sudo cp /usr/bin/qmake /usr/lib/i386-linux-gnu/qt4/bin/

первые два пункта мне сегодня не пригодились, но выполнить их советую, а то мало ли что. если последний пункт не поможет, выполните

which qmake

а то вдруг она у вас лежит не в /usr/bin/ а хуй знает где ещё.

Вообще по идее система должна ставить qmake пятой версии в /usr/lib/i386-linux-gnu/qt5/bin/qmake и сразу понимать что qmake лежит именно там. Но сами понимаете, это же линукс, тут нихуя без напильника не работает.

Но в результате qmake перестала ругаться что версия должна быть минимум 5.2.0 и заработала как надо

i56.fastpic.ru

так что теперь сижу жду пока она соберёт мне makefile.
name
Ubuntu Qt тупак лень было дойти до нетбука с убунтой, решил скомпилить 200+ мб исходников "по-быстрому". уже час смотрю на это i.snag.gy
мораль — скупой платит дважды. не выёбывайтесь, качайте гуёвые инсталлеры и будет вам счастье.