• ставлю значит я jabber-бота gluxi на freebsd, а он просит поставить qt4, а он в свою очередь танет за собой KDE. вот я думаю, зачем консольному боту qt4? каким местом он его пользует?

Replies (3)

  • @lastormo, Может быть ему надо сказать что-то вроде WITHOUT_X11=yes?
  • @lastormo, @bm там надо компилировать с помощью команды cmake, а в CMakeLists.txt 25й строчкой идет FIND_PACKAGE(Qt4 REQUIRED). я С++ не шарю
  • @lastormo, @PantiL может я что-то не так понимаю? но:
    root# cd /usr/ports/devel/qt4/
    root# make
    ===> qt4-4.4.3 depends on package: qt4-accessible>=4.4.3 — not found
    ===> Verifying install for qt4-accessible>=4.4.3 in /usr/ports/accessibility/qt4-accessible
    ===> Vulnerability check disabled, database not found
    ===> Extracting for qt4-accessible-4.4.3
    => MD5 Checksum mismatch for KDE/qt-x11-opensource-src-4.4.3.tar.gz.
    => SHA256 Checksum mismatch for KDE/qt-x11-opensource-src-4.4.3.tar.gz.
    ===> Refetch for 1 more times files: KDE/qt-x11-opensource-src-4.4.3.tar.gz KDE/qt-x11-opensource-src-4.4.3.tar.gz
    ===> Vulnerability check disabled, database not found
    => qt-x11-opensource-src-4.4.3.tar.gz doesn't seem to exist in /usr/ports/distfiles/KDE.
    => Attempting to fetch from ftp.iasi.roedu.net
    fetch: ftp.iasi.roedu.net File unavailable (e.g., file not found, no access)
    => Attempting to fetch from ftp.ntua.gr
    и так далее...