← All posts tagged cabal

fmap

cabal install xmonad-extras --reinstallResolving dependencies...
cabal: dependencies conflict: ghc-7.4.1 requires containers ==0.5.0.0 however
containers-0.5.0.0 was excluded because ghc-7.4.1 requires containers
==0.4.2.1
containers-0.5.0.0 was excluded because libmpd-0.7.2 requires containers >=0.3
&& <0.5

Первый, странно звучащий, конфликт наверно идет от какого-то пакета из списка зависимостей xmonad-extras, потому что

cabal info xmonad-extras | grep containers xmonad-contrib ==0.10.*, base >=3 && <5, containers -any,

и неясно отчего оно требует именно 0.5.0.0? Причем глобально extras ставится, а локально вот такое вот вылазиет. Это с версиями (0.10.1|0.10.1.1), а 0.9 вообще не собирается.