• дыбр Haskell погроммирование СЯУ, что ghc-mod распространяется под лицензией AGPL и не поддерживается компилятором 8.6.

    в пулл реквестах есть экспериментальный упоротый билд с поломкой обратной совместимости..

Replies (2)

  • @agr, Ну вообще ghc-mod считается устаревшим (даже пакет на hackage последний раз обновлялся в 2017-ом, не удивительно что он не совместим с GHC 8.6).

    Сейчас в моде HIE.
  • @seniorantonymous, кстати, да, но всё это представляет интерес лишь такой, что нужно вывести функции тип по положению в сорце и результату тайпчека.. т.е. ни ghc-mod, ни HIE для решения задачи не нужны..