• Debian Asterisk А вот что делать в дебиане вот с такими вещами?


    The following packages have unmet dependencies:
    libstdc++6: Depends: gcc-4.6-base (= 4.6.0-2) but 4.6.0-3 is to be installed.
    asterisk: Depends: libgmime-2.0-2a which is a virtual package.
    libgomp1: Depends: gcc-4.6-base (= 4.6.0-2) but 4.6.0-3 is to be installed.
    The following actions will resolve these dependencies:

    Keep the following packages at their current version:
    1) asterisk [Not Installed]
    2) build-essential [Not Installed]
    3) g++ [Not Installed]
    4) g++-4.5 [Not Installed]
    5) gcc [Not Installed]
    6) gcc-4.5 [Not Installed]
    7) gcc-4.6-base [4.6.0-2 (now)]
    8) libgcc1 [1:4.4.5-8 (now)]
    9) libstdc++6-4.5-dev [Not Installed]

    Leave the following dependencies unresolved:
    10) asterisk-config recommends asterisk
    11) dpkg-dev recommends gcc | c-compiler
    12) dpkg-dev recommends build-essential
    13) libc6-dev recommends gcc | c-compiler

Replies (25)

  • @Zert, запустить aptitude, и повторить. Выбрать вариант решения. Какой-то пакет наговнил.
  • @Zert, там если отвечать нет, то предложат другие варианты разруливания
  • @zamotivator, это и была аптитуда
  • @L29Ah-banned, это я сам знаю. мне надо ебиан.
  • @Fangel,
    Accept this solution? [Y/n/q/?] n

    ** No more solutions available **
  • @Zert, "n" отвечай
  • @Zert, какие были последние действия? Ты там наговнял явно чего-то
  • @Fangel, и он повторяет одно и то же предложение разруливания
  • @Zert, еще рекомендуемые отрубить
  • @zamotivator, а как можно наговнять? вроде бы ничего такого не делал
  • @Zert, еще может что-то у тебя зафиксировано на одной версии
  • @Fangel, а как это?
  • @Fangel, отрубил, аптитуда тут же завершилась.
  • @Zert, смешивал репозитории (когда занимаетсь анальным сексом и сменяете отверстие девушки, не забудьте поменять презерватив, иначе можно занести инфекцию во влагалище), поставил пакет из левого репоса, нашаманил вокруг recommended зависимостей. Смотри последние транзакции, и ищи виновника.
  • @Zert, libstdc++6: Depends: gcc-4.6-base (= 4.6.0-2) but 4.6.0-3 is to be installed
    вот тебе ответ. Отрубай лишние репы и ставь нужную gcc а потом рули зависимости
  • @Zert, рекомендуемые отрубаются через конфиги
  • @Fangel, а это тебе предлагали вариант как разрулить зависимости автоматически
  • @Fangel, я сегодня востанавливал сквизи с подобными поломаными зависимостями, оставил одно основное зеркало и все разрулилось, дальше легче пошло, даже после подключения других репов
  • @Zert, ЭНДЖОЙ ЕР СИД!
  • @Zert,

    судя по "libstdc++6: Depends: gcc-4.6-base (= 4.6.0-2) but 4.6.0-3 is to be installed.", gcc-4.6-base до ftp доехал, а libstdc++ из того же сорца — еще не успел.

    за такое надо бы по ебалу
  • @Zert, ну да, 4.6.0-3 как раз 14 часов назад в сиде и собрался, кто бы блядь сомневался.

    buildd.debian.org
  • @Zert, не выёбываюсь и пользуюсь аптитудом. это он такое пишет.
  • @Zert, зерте, ну яж тебе сказал все. сделай apt-get update, и смотри полиси на libctdc++6. если там говно, то переключись на другое зеркало или просто подожди.

    ибо это ебаный сид и говно в репозитарии
  • @mrmcc, уже поставили на другой виртуалке в чистом сквизе.