← All posts tagged cubietruck

Strephil

В прошлый раз я забросил Cubietruck с неработающим Wi-Fi.
Сейчас, пока за окном вьюга, и фоткать слизевики никак не выйдет, а тян нет и не предвидится, я решил попердолиться с Cubietruck'ом: поробовал установить дристобутив с относительно свежим, 4.7.3, ядром.
Оказалось, что Cubietruck охотно подключается к домашнему говнороутеру, но совсем не хочет подключаться к десктопу с Arch'ем…

Strephil

Пытаюсь использовать Cubietruck типа в качестве домашнего NAS: храню там фоточки.
Какое же это глюкалово! После обновления отвалился WiFi. Потом поломался nand, а там загрузка с nand у меня. Всё, не грузится. UART наружу не выведен, приходится развинчивать.
Загрузился с карточки, хорошо nand починил. Но что с wifi и как его починить WiFi — не понятно.

Strephil

В осенний день поигрался с Cubietruck.
Решил попробовать установить Armbian (Jessie, ядро 3.4.108) на sata-диск. Загрузился с sd-карточки. Внезапно не работает Ethernet, это во-первых, на sata-поставился, но с внутреннего nand-а не грузится. Как-то не очень. И, главное, ethernet не работает, и совсем не понятно, почему. Пробовал вводить разные команды — не помогает, и вообще не понятно, с какой стороны подступиться.
Попробовал запустить с карточки Cubian. И ethernet сразу заработал! Хм.
Записал на карточку Armbian. Загружаюсь — ethernet работает. Устанавливаю на Sata — не работает, с nand не грузится.
Посмотрел, оказалось, что скрипт установки криво разметил nand. Я руками повторил несколько команд из скрипта — буквально те же самые команды, просто повторил руками — вроде бы, теперь грузится (и ethernet работает).
На Armbian не работает выключение, вместо выключения игрушка перезагружается, а в Cubian'е выключение работает нормально.

Strephil

попробовал какой-то образ для cubietruck, записал на sd-карточку. не грузится, сразу же, с самого начала, пишет: mmc failed. хорошо. Записал другой образ для cubietruck на ту же sd карточку, вроде загрузилось что-то. ладно. Записал первый образ на другую sd-карточку, вроде загрузилось, но чё-то не работает.

Strephil

Засунул в ewell case, подключил монитор, включил, загрузился, дошел до экрана логина, ну тут можно выключать. Нажал на кнопку — а он почему-то не выключается. Выдернул кабель — а он от батарейки работает. Ждать, когда сядет?..

Strephil

Вот!
У меня же две Cubietruck — Cubieboard-3. На первую установить не получилось, так у меня же их две.
Догадался засунуть карточку во другую борду — и всё поставилось нормально.

Тем сложнее будет разобраться, что делать с первой. :-(