• Ubuntu говно Убунта притесняет русских:
    ```
    $ do-release-upgrade -p 18.10
    Проверка наличия нового релиза Ubuntu
    Ваша версия Ubuntu больше не поддерживается.
    Traceback (most recent call last):
    File "/usr/bin/do-release-upgrade", line 135, in <module>
    "%(url)s\n") % { 'url' : url })
    ValueError: unsupported format character '?' (0xa) at index 55

    shura [/home/shura]$ LANG=c; do-release-upgrade
    Checking for a new Ubuntu release
    Your Ubuntu release is not supported anymore.
    For upgrade information, please visit:
    ubuntu.com

    Get:1 Upgrade tool signature [819 B]
    Get:2 Upgrade tool [1260 kB]
    Fetched 1261 kB in 0s (0 B/s)
    authenticate 'bionic.tar.gz' against 'bionic.tar.gz.gpg'
    extracting 'bionic.tar.gz'
    ```
    И пошла обновляться...
    ♡ recommended by @O01eg

Replies (6)

  • @Shura, Типикал питонопроблемы с кодировками, не надо искать тут теорию заговора
  • @Shura, Боюсь, от этого не застрахован ни один дистриб
    Но все же лучше не пользовать форки, а пользоваться чем-то постабильнее — в случае спрыга с убунты идеально просто уйти в debian. Правда, там софт апдейтят крайне медленно — на том оно и держится.
  • @lv, От чего именно «от этого»? От /1?
  • @vt, Питоша до сих пор думает что единственно правильная русская кодировка это ISO 8859-5? :)
  • @lv, Большинство разрабов дебиана, как и бубунты англоговорящие, посему другие локали мало кто тестит. Переключалку раскладки во второгноме делал руский — она была довольно удобной. Когда вышел третьегном сей разработчик решил завязать с этим ужасом и перестал туда контрибутить. С тех пор переключалка в гноме перманентно сломана и малоюзабельна.
  • @Renha, от косяка с локалями.