• Ubuntu Eclipse zend 14.04 У меня на ubuntu 14.04 какая-то страннота творится. Eclipse запускается, а Zend Studio падает с ошибкой. Перепробовал уже все доступные java от openjdk6 до oracle java 8. Ни в какую.
    Кто-нибудь может опровергнуть или подтвердить этот факт?

Replies (7)

  • @RA, Ты думаешь телепаты читают тебя и сразу же угадают текст ошибки?
  • @vt, # A fatal error has been detected by the Java Runtime Environment:
    #
    # SIGSEGV (0xb) at pc=0x00007ff71cdd62a1, pid=6289, tid=140700792203008
    #
    # JRE version: Java(TM) SE Runtime Environment (7.0_55-b13) (build 1.7.0_55-b13)
    # Java VM: Java HotSpot(TM) 64-Bit Server VM (24.55-b03 mixed mode linux-amd64 compressed oops)
    # Problematic frame:
    # C [libsoup-2.4.so.1+0x6c2a1] soup_session_feature_detach+0x11
    #
    # Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
    #
    # An error report file with more information is saved as:
    # /home/ra/Programs/ZendStudio10/hs_err_pid6289.log
    #
    # If you would like to submit a bug report, please visit:
    # bugreport.sun.com
    # The crash happened outside the Java Virtual Machine in native code.
    # See problematic frame for where to report the bug.
  • @RA, Вот здесь bugs.launchpad.net рекомендуют вписать
    -Dorg.eclipse.swt.browser.DefaultType=mozilla
    to the vmargs in eclipse.ini
    не помогло. Тогда с такой ошибкой
    GLib-GObject:ERROR:/build/buildd/glib2.0-2.40.0/./gobject/gobject.c:4215:g_weak_ref_set: assertion failed: (weak_locations != NULL)
  • @RA, запускаешь sun java, а читаешь баги openjdk? Вон же написано, у тебя чтото с libsoup, вот в ней и поищи проблемы.
  • @RA, хоть бы ошибку показал, что ли
  • @RA, тогда у тебя что-то с свт, попробуй другую версию, более свежую или из реп. Этим и хороша ява что отмежовывается от нативного кода, но свт устраняет это преимущество. Похоже у тебя в системе стоит гтк3, а свт слинкован с версией 2