← All posts tagged совместимость_версий_.NET_Framework

Ilya-S-Zharskiy
windows-xp последняя_версия Powershell-WinRM .NET-Framework-2.0-3.0-3.5 совместимость_версий_.NET_Framework Для установки Powershell для WinXP нужно .NET Framework 2

Но он отменён и заменён, внезапно,
на 3.5.1

А ещё, как обычно, у этого всего есть сервис-паки (SP),
причём в разных местах называющиеся по-разному:
в одном — Service Pack, в другом — просто Critical Update

Тут уж лучше сразу начать с руборда:

Microsoft .NET Framework 3.5 SP1 Redistributable Package
+ LangPack
+ KB958481 KB958483 KB958484 + KB963707 + KB974417 + KB976126

Версия 3.5 SP1 включает в себя версии 2.0 SP2 и 3.0 SP2.

В начале установки делает попытку соединения с интернетом
для закачки языкового пакета.
Если этот пакет у вас уже имеется, установку следует производить
будучи отключенным от сети. После нескольких неудачных попыток подключения
установка продолжится в обычном режиме.

Эта версия входит в состав операционных систем Windows 7 и Windows Server 2008 R2.

forum.ru-board.com


catalog.update.microsoft.com


Microsoft .NET Framework 3.5 Service Pack 1 and .NET Framework 3.5 Family Update (KB951847) x86

ndp35sp1-kb958484-x86_8b5036b48590c52e3edba8e297cd3017b7a3043c.exe
download.windowsupdate.com

ndp20sp2-kb958481-x86_04fcde4b28dd4f6db7548831d35d1c6bf38e1335.exe
ndp30sp2-kb958483-x86_2b03b54c0972c16ab6ce75f42ac4877af87ce844.exe

dotnetfx35_x86_1aab3734ef80ad9a9ea342c887c3ea76340961e8.exe
download.windowsupdate.com
52,3 МБ



Microsoft .NET Framework 3.5 Service Pack 1 and .NET Framework 3.5 Family Update for .NET versions 2.0 through 3.5 (KB951847) x86

dotnetfx35_x86_1aab3734ef80ad9a9ea342c887c3ea76340961e8.exe

download.windowsupdate.com

ndp30sp2-kb958483-x86_2b03b54c0972c16ab6ce75f42ac4877af87ce844.exe
ndp20sp2-kb958481-x86_04fcde4b28dd4f6db7548831d35d1c6bf38e1335.exe
ndp35sp1-kb958484-x86_8b5036b48590c52e3edba8e297cd3017b7a3043c.exe

download.windowsupdate.com








Ilya-S-Zharskiy
windows-xp последняя_версия .NET-Framework-4 совместимость_версий_с_Windows совместимость_версий_.NET_Framework The .NET Framework 4.5 and later versions are not supported on Windows XP, but on Windows Vista, Windows 7 and later versions of Windows.

If you need to run an app that requires the .NET Framework 4.5 or later, you will to upgrade to a later version of Windows or find another machine that has a later version of Windows. You can also contact the publisher of the app, to see if they support Windows XP with another version of their app.

The .NET Framework 4 is supported on Windows XP, however, it will not run apps that require .NET Framework 4.5 or later versions.



microsoft.com

Microsoft .NET Framework 4 (автономный установщик)


Поддерживаемая операционная система

Windows 7; Windows 7 Service Pack 1; Windows Server 2003 Service Pack 2; Windows Server 2008; Windows Server 2008 R2; Windows Server 2008 R2 SP1; Windows Vista Service Pack 1; Windows XP Service Pack 3

Windows XP SP3
Windows Server 2003 SP2
Windows Vista SP1 или более поздняя версия
Windows Server 2008 (не поддерживается в основной роли сервера)
Windows 7
Windows Server 2008 R2 (не поддерживается в основной роли сервера)
Windows 7 SP1
Windows Server 2008 R2 SP1
Поддерживаемые архитектуры:
x86
x64
ia64 (некоторые возможности не поддерживаются на ia64, например WPF)
Аппаратные требования:
Рекомендуемый минимум: процессор Pentium с тактовой частотой 1 ГГц или выше, 512 МБ оперативной памяти или больше
Минимальное место на диске:
x86 – 850 МБ
x64 – 2 ГБ
Предварительные требования:
Установщик Windows 3.1 или более поздней версии
Internet Explorer 5.01 или более поздней версии

download.microsoft.com
dotNetFx40_Full_x86_x64.exe
microsoft.com

Microsoft .NET Framework 3.0 XP x86 x64 (KB928416) — 2008
catalog.update.microsoft.com


catalog.update.microsoft.com
Microsoft .NET Framework 4.6.1 в Windows Server 2012 R2 для 64-разрядных систем (KB3102467) — 2016


catalog.update.microsoft.com
Обновление для платформы Microsoft .NET Framework 4 в Windows XP, Windows Server 2003, Windows Vista, Windows 7, Windows Server 2008 для систем на базе x86 процессоров (KB2468871) — 2011
go.microsoft.com
download.windowsupdate.com
Update for Microsoft .NET Framework 4 on Windows XP, Windows Server 2003, Windows Vista, Windows 7, Windows Server 2008 x86 (KB2468871)
microsoftfixit50735_579b2d12894af17daa70bd153b14fbfddefa0ad8.exe
ndp40-kb2468871-v2-x86_8cb1f5eb7eda5329e69629dff3fd3757bf980717.exe

Всё, я запутался!

forum.ru-board.com

dotNetFx40_Full_x86_x64.exe

Версия 4 не включает в себя предыдущие версии (1.0, 1.1, 2.0, 3.0, 3.5),
не требует их наличия при установке и не заменяет их.

Client Profile предназначен для пользователей
и обеспечивает запуск приложений
использующих функции платформы NET Framework 4.

Full содержит дополнительные функции, не включенные в Client Profile,
предназначенные для разработчиков приложений.