to post messages and comments.

Как заставить emacs работать и с clojure, и sbcl

1. установить slime and slime-repl from elpa
— устанавливает версию 20100404.1, но только кусочков slime, необходимых для работы с clojure. Т.е. не устанавливает *.lisp файлы

2. Установить соотв. копию slime:
— cd ~/src/elisp
— cvs -d :pserver:anonymous:[email protected]:/project/slime/cvsroot co -D 20100404 slime

3. Добавить строчку в .emacs:
(setq inferior-lisp-program "sbcl")

4. M-x slime запустит slime 20100404 с sbcl. Почему-то говорит о version mismatch, что, мол swank оказывается от 20100403. (если подтвердить, то дальше, вроде, работает)

5. открыть файл из проекта созданного lein -> M-x clojure-jack-in