to post messages and comments.

Что-то я в сомнении. После установки py27-hgsubversion из портов мне всё равно пришлось вписывать в hgrc чудовищную строчку

hgsubversion = /opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/hgsubversion

— причём сначала раскопать, куда в портах hgsubversion вообще ставится.

Что я делаю не так? Разве hgsubversion не должен был включиться при установке сам?

Поставить #Kaffe или OpenJDK6 из MacPorts не удалось. Крайне ненадёжная это вещь — сорцовые репозитории.

GCJ в принципе не поддерживает J2SE 6.0. Не видать мне, похоже, шестой джавы на макосе как своих ушей.

Спасибо за mxcl.github.com , @Constantiner . Ставится он с ошибкой — $PATH первым, а должен быть вторым (/usr/local/bin:$PATH), но после этого исправления все круто. Не нужен такой же полноценный менеджер пакетов как в unix. Не нужен. Потому что установка чего-то из пакета на маке — редкое и опасное для собственного спокойствия действие. Никогда нельзя ставить gimp из портов. А вот мавен и гит — без проблем.

Мейнтейнеры пакетов maven&mercurial тормоза. И я сам тормоз, что никак не исправляю процесс. Актуальные значения для порта:
version 1.4
checksums md5 951ebd4a8153eaa3c56fc0ce2575ab70 \
sha1 4ab0a027cdd8dfc57077a9d599e8ead550d4d116 \
rmd160 2f7f4eb7eb684a4a064cb0234361da1524805b9f