Жаба мне снесла root корневой раздел. Точнее попыталась. Т.к. прав нет никаких то удалила /home
Со всем. Конфиги, настройки, ключи — всё улетело нахрен. Какие то доки, проекты, сорцы....
Жалко только ключи и настройки. Документация вся в иторнетах, почта там же. проекты — там же. Книги — их тьма в телеге и на трекерах... А вот ключи и настройки, вот этого вот нет, так что всё настраивтаь таки заново.

Особый привет глючным либам в недрах которых могут быть shutDownHook с удалением рабочего каталога!!

Обнаружил странное поведение: если запускать zim из ``yakuake``, то он запускает нестандартной цветовой гамме, то есть цвета отличаются от тех, в которых zim отображается при запуске любым другим способом. Оказалось, что у yakuake несколько отличаются переменные окружения от других программ, запущенных в моём сеансе. Вот эти 2 переменные у других программ отсутствуют:
$ strings proc$(pidof yakuake)/environ | grep RC_FILES | sed "s|$HOME|\$HOME|g"
GTK_RC_FILES=/etc/gtk/gtkrc:$HOME/.gtkrc:$HOME/.config/gtkrc
GTK2_RC_FILES=/etc/gtk-2.0/gtkrc:$HOME/.gtkrc-2.0:$HOME/.config/gtkrc-2.0
Ну и собственно ``$HOME/.config/gtkrc-2.0`` и приводит к странным цветам (на диске есть и он, и ``$HOME/.gtkrc-2.0``). Откуда же берутся эти переменные окружения? Эксперименты показали, что они выставляются для программ, запускаемых восстановлением предыдущего сеанса (настройки KDE -> desktop session -> On Login — restore previous session). Уже довольно странное поведение, не так ли? Вот только баг похоже не в том, что при восстановлении сеанса выставляются эти переменные, а в том, что для прочих приложений они не выставляются! В ``$HOME/.config/gtkrc-2.0`` лежат настройки цветовой схемы, которые KDE записывает при включённой опции settings -> colors -> "Apply colors to non-Qt applications". Вообще сурово. Дальше расковыривать этот баг мне расхотелось.

А ещё недавно обнаружил, что KDE корзина игнорирует размер скрытых объектов. Это фигню я перепроверю после обновляшек и расскажу. Вообще смешная.

Что ж всё-так глючит-то, а? :(

Очень интересный баг словили в навигационной системе при первом запуске с этим разгонным блоком с космодрома Восточный. РН штатно крутанул после старта весь стэк вокруг своей оси на 174 градуса в одну сторону, а с точки зрения разгонного блока нужно було крутить на 186 градусов в другую. Поэтому после отделения он решил исправить ситуацию крутанувшись еще на 360, но не успел. Успел только на 60, прежде чем через минуту включился главный двигатель. На Байконуре и Плесецке баг не проявляется по причине отсутствия кручений больше чем на 140 градусов.

Чем то напоминает первый запуск Ариана 5, где словили цифровое переполнение акселерометра рассчитанного на ленивый профайл запуска Ариана 4.

Еще забавно что подробности я обычно узнаю с форума nasaspaceflight и других англоязычных ресурсов. russianspaceweb.com

в приложении под андроид замечена ещё одна бага.

1. заходим в приложение.
2. дожидаемся push #1, новый пост.
3. дожидаемся push #2, новый комментарий к существующему посту.
4. выкидываем push #2, переходим по push #1.

ER: открылся новый пост из push #1
AR: открылся пост с новым комментом из push #2.

странный баг, который можно воспроизвести следующим образом:

1. установить приложение, бету, на андроид, ахуавей.
2. зайти в тред.
3. оставить комментарий с картинкой.

ER: коммент с картинкой добавится.
AR: сообщение с ошибкой.

WA. попробовать добавить пост с картинкой. приложение запросит права на доступ к sd карте, ошибка перестанет воспроизводиться.

Собираторы в fedoraproject чего-то там странное курят.
Собрали firefox 55 для 26й федоры.
Положили в репозитарий.
А оно не ставится — стоит зависимость от пакета, которого в репах нет.
>nothing provides nspr = 4.16.0 needed by firefox-55.0.2-1.fc26.x86_64
А в системе только 4.15

Баг починили, но добиться от системы понимания не удалось. В результате выкачал bodhi.fedoraproject.org и руками установил нужный пакет (предварительно грохнув стоявшую 54ю версию).

Не фана для, но чтобы скрипт на апдейт работал, как надо.

Понадобилось работать в Eclipse. Запускаю, создаю проект, пытаюсь запустить отладку... чувствую, всё как-то долго. Всё время подвисают окна, процессы, отладка... работать невозможно! Постоянно виснет отладка, не реагирует на кнопки.
Короче, выяснилось что это известный баг, связанный с GTK3: bugs.launchpad.net
Есои добавить
export SWT_GTK3=0
перед запуском бинарника, то программа оживает!

Какой-то странный баг фокса.
Когда фокус в input и переключаешь раскладку клавиатуры (у меня по CapsLock), то input получает событие onblur и сразу onfocus.
Это ломает поведение на некоторых сайтах, например trello.com .
Гуглеж ничего не подсказал.
Что делать-то?

Нашел в S7 edge очередной самсунго баг. Если ставишь апк файл менеджер и разрешенные неизвесные источники и кликаешь на ярлык на рабочем столе, то он каждый раз будет рестартовать приложение заново. Берешь туже арпшку делаешь "adb install " и оно перестает перезапускать приложение.

Когда уже Ким Чен Ир грохнет этих южнокорейских быдлокодеров...