to post messages and comments.

У Komodo Edit по сравнению с «текст-мейтом» обнаружено две киллер-фичи: редактирование файла по SCP (да, такого не должно требоваться, но иногда требуется) и, как ни смешно, поддержка кодировок (см. #1651478). А вот интересно, как у него с go to file и go to symbol?

У TextMate всё-таки нашлось слабое место: идеологически выверенное отсутствие поддержки кодировок. Жаль, что оно так.

С аргументами автора можно согласиться, а вот понять апологетов этого редактора, которые в ответ на вопрос «Как работать с файлами в кодировке foo?» отвечают, дескать, надо пользоваться UTF-8. Надо, кто ж спорит. Но у большинства спрашивающих есть системы, которые эту кодировку тащат с давних времён. У меня, например, движок сайта на питоне с несколькими инсталляциями, родом из 2005 года, не-unicode-aware вообще. Перевести на UTF-8 можно (и нужно), но переход сам по себе — масштабный проект. Думаю, у других так же. Когда вот так походя бросают «Да iconv-ом перегнать и делов-то», хочется взять и... объяснить. :)

Посмотрел на SublimeText. Не понял, в чём его отличительная особенность. Умной навигации а-ля TextMate (найти файл, найти символ) я там не нашёл (плохо искал?). В чём фишка? В миниатюре текста? Или в богатом графикой интерфейсе?

Мне тут слухи дошли, что опытные маководы часто жалуются на TextMate и поглядывают с завистью в сторону Notepad++. 1) Правда ли, что TextMate уже не устраивает маководов? 2) А Notepad++ уже стал приличным редактором? А то я его видел года четыре назад последний раз и больше никогда не смотрел на него.

Поставил таки ради интереса RedCar (клон TextMate на Ruby + Java). Сейчас пользуюсь Sublime Text 2 (тоже клон Sublime Text 2, написан на Python). Запущенный Sublime Text 2 (с открытым одним проектом, но без активных вкладок) занимает 35 метров оперативы. RedCar благодаря его привязке к Java, без открытых проектов вовсе занимает 200> метров. Вот думаю, зачем есть RedCar, который жрет память как мерин? Легче поставить NetBeans или Aptana Studio )

Кажется слава TextMate не дает покоя многим. Помимо Sublime Text, оказывается виндовый E Text Editor. Как и Sublime Text, он платный, только вот пользоваться бесплатно и официально им долго не получится, только 30 дней. Сейчас поставим посмотреть таки )

Однако, проблемы есть везде. К примеру, для того, чтобы в RoR-бандле заработала фича "Install Plugin" советуют вместо ruby 1.8.7 поставить ruby 1.8.6 или 1.9-ветку. Да ну нахуй, я и руками плагин поставить могу.

Если не работает "Run behavior description — Rspec" (вроде и не нужно, через терминал проще, но все таки). /Bundles проверьте где у вас . ~/Library/Application\ Support/Textmate/Bundles. И еще вот blog.dnite.org