to post messages and comments.

На винде увидел каким то макаром все Unity пакеты и заработал на проекте. Из проблем только то что Editor модули не видят не эдитор модули и в зависимости их пока никак нельзя указать. Под MacOs managed dll-ки от юнити я не нашел как прописать (настроект проекта нет совсем) и проект хоть и открылся, но без UnityEngine пакета там делать нечего. А так это просто килер MSVS+Resharper

15-я версия сего чуда, по-прежнему нужно делать одну и ту же массу приседаний для того, чтоб начать пользоваться:
0) у них в конторе есть хоть один человек, который запускал это поделие БЕЗ импорта настроек?
1) почему меня заваливают кучей модальных окошек, включая такие модные в 1998 году tips and tricks?
2) я хочу импортировать проект, у них никто не пробовал это делать на чистой установке и не знает, что надо сначала создать проект, найти там JDK, потом вернуться назад и продолжить импортировать, ибо в окне импорта нет поиска JDK?
3) зачем я должен менять шрифт с courier на consolas? Они не могут в 2015 году прочитать, какой у меня в системе моноширинный шрифт?
4) у них вообще есть человек, который запускал Xcode, Sublime, Atom, они не понимают что они застряли в 98 году по перегруженности интерфейса? А ведь раньше они были легкой заменой эклипса, есть подозрение что эклипс уже полегче.

url video
Один я жду, когда выйдет IDE от JetBrains для C++? Посмотрел превью-видео и впечатлился. Проект хранится в CMakeLists.txt, то есть никаких проблем и лишней возни с миграцией старых проектов и работой с людьми, которые предпочитают Vim/Emacs. Бальзам на душу. Про остальное — надо смотреть видео: youtube.com

*Jabber
Кстати, если кто-то ещё не знает. Их YouTrack имеет свой JID (Jabber ID) и с ним можно поговорить.
1. Удобно отслеживать изменения;
2. Удобно комментировать таски;
3. Он вообще умный и понимает команды разные.
[email protected] <mailto:[email protected]>

о! Наконец то пофиксили мою багу, и теперь лайв-эдит плагин работает и в пай-чарме. Красота! Кстате, jetbrains молодцы, дают опен сорс лицензии, я такой вот пользуюсь.

А PHPStorm 5.0.4 ничего так... Вроде чистенько работает, без багов. Ошибок много детектит. Можно пользоваться тем кто вынужден писать на PHP. Версия 5.0.1 у них была вся бажная, а это вроде норм.

Моя основная проблема с Idea, это как блин создать новый проект ^_^. Вот хочу создать новый проект, в существующем Мавен проекте (но это будет отдельный модуль) Проект на Флексе, но сам модуль на Скале – что мне делать? Открыть текстмейт и все написать =)

кратко итоги дискуссии с представителем JetBrains по поводу моего недовольства PyCharm — их новой и вцелом весьма неплохой IDE для Python (@intelliyole в твиттере выловил мои репосты отсюда):
— жирный плюс в карму. все бы так (терпеливо и оперативно) реагировали на критику пользователей
— автокомплишн для декораторов обещали поправить в ближайшее время (хотя мне по прежнему текущее поведение кажется мега загадочным)
— говорит, что бинарные модули комплитятся нормально. нужный мне PyQt — особый случай, требующий специального напильника (фиксится).
хорошо, коли так, но сильно насторживает: во-первых это оставляет немалую вероятность для поломки иных "особых" модулей в будущем (не по одному же их сабмитить?). во-вторых — сильно попахивает велосипедостроительством (сомневаюсь, например, что шеллы ipython/bpython самостоятельно пытаются разобраться в частных случаях), вместо использования стандартных модулей. проблему не исследовал, но наверняка все случаи покрываются каким-нибудь:
["%s %s" % (m, p and '[package]' or '[module]') for _, m, p in pkgutil.walk_packages(PyQt4.__path__, PyQt4.__name__+'.')]
— про шорткат для автокомплишена (Ctrl+Space вместо всем привычного под маком Esc) аргументы таковы: (1) сочетание не является стандартным (в отличие от Meta+Space) (2) не всегда есть возможность следовать за мэйнстримом (3) перестанут закрывать диалоги по Esc, а там тоже автокомплишн
(1) просто не правда. скриншот с системными настройками привел, сочетание забито под общесистемный поиск
(2) по-моему это один из тех случаев где можно (неоднократно продемонстрировано другими) и нужно (чтобы девелоперы с опытом разработки на мэйнстримных продуктах — читай "большинство" )не исплевались
(3) во-первых, это проблемы разработчика, а не оправдание. делайте зависимым от фокуса или еще как, только не заставляйте всех переучиваться из-за того что вам фишечку захотелось прикрутить. во-вторых, автокомплишн в диалогах — не интуитивен и не нужен по смыслу. в-третьих, интереса ради попробовал и оно скорее не работает в диалогах, чем наоборот.
Итог: общаться с компанией приятно, шорткат я уже давно сам поменял, хоть и раздражен, фиксов с нетерпением ждем.
P.S. надеюсь мне никогда больше не придется переписывать через твиттер :)