Чтобы добавлять сообщения и комментарии, .

@Hawat:
Hawat

Чего-то не понимаю, ставлю python3-virtualenv, а virtualenv в системе не появляется.

@lv:
lv

Вот все говорят, что человечество безумно много сил и ресурсов спускает в свисток.
Мол, все эти юзер-френдли, кастомерс-аддикт продукты — это лишние ресурсы, которых у человечества итак нет.

Предполагается, что в том месте, где не сулит прибыль, придури и бездумного расходования ресурсов нет.

Все мы следили и следим за развитием событий вокруг внедрения systemd в различные дистрибутивы. Не стал исключением и дистрибутив Linux — Debian, вокруг которого разгорелись нешуточные страсти.
Часть сообщества недовольного внедрением systemd в Debian, гордо называющие себя Veteran Unix Admins, откололись от Debian. Они основали свой форк Devuan, целью которого обозначили создание дистрибутива с возможностью выбора системы инициализации и защиты интересов сторонников классической организации работы Debian.
habrahabr.ru

И чтобы те, которые не:
systemd — демон инициализации других демонов в Linux, пришедший на замену используемого ранее стартового демона /sbin/init. Его особенностью является интенсивное распараллеливание запуска служб в процессе загрузки системы, что позволяло существенно ускорить запуск операционной системы. Однако, после добавления веб сервера и журналирования, скорость упала. Название происходит от принятого в Unix добавления суффикса «d» к демонам.
ru.wikipedia.org

Я это все к чему? С днем, погромисты! Пусть ваш код приносит человечеству пользу, а не лулзы.

@Hawat:
Hawat

NetworkManager прибили зависимостями к systemd

@Hawat:
Hawat

Забавно, вроде что в первом, что во втором linux-4.2, но мультимедийные клавиши макбука(RaiseVolume, LowerVolume) корректно отрабатывают только на devuan.

@Hawat:
Hawat

network-manager в debian[а может и везде] не умеет l2tp-over-ipsec из коробки, говна кусок.

@justonemore:
justonemore

This is, in my mind, orthogonal to the systemd question. I used to be able to say Linux was clean, logical, well put-together, and organized. I can’t really say this anymore. Users and groups are not really determinitive for permissions, now that we have things like polkit running around. (Yes, by the way, I am a member of plugdev.) Error messages are unhelpful (WHY was I not authorized?) and logs are nowhere to be found. Traditionally, one could twiddle who could mount devices via /etc/fstab lines and perhaps some sudo rules. Granted, you had to know where to look, but when you did, it was simple; only two pieces to fit together. I’ve even spent time figuring out where to look and STILL have no idea what to do.
changelog.complete.org

@OCTAGRAM:
OCTAGRAM

В CentOS sftp не поддерживает рекурсивный get. Поэтому с Debian приходится делать рекурсивный put

@OCTAGRAM:
OCTAGRAM

Переношу сервак с Debian на CentOS. Там всё по–другому! И мой хороший скрипт для init.d вообще не заработал, всё переделывать надо.
/lib/lsb/init-functions: No such file or directory
Думал, ну хоть это останется. Нет. Что, CentOS не чтит LSB?

@ng358ex-2:
ng358ex-2

Только вчера узнал что Яна Мердока с нами нет с ноября 2015го. Умер при необычных обстоятельствах, неясно самоубийство это или насильственная смерть.

@Hawat:
Hawat

У debian и centos есть варианты образов netinstall(247mb у debian, 367mb у centos). В случае с debian мы получаем полноценный инсталятор(как tui так и gui) с минимальным набором пакетов, если дать доступ в интернет то он выкачает более новые версии и в конце помимо прочего предложит поставить X'ы с DE-шкой(который на netinstall нет).
У CentOS...все плохо у CentOS, вы получаете полноценный инсталятор(как и в полной версии gui-only), но без базовых пакетов, то есть на определенном этапе надо обязательно настроить доступ в интернет и указать путь до репозитория. Ну ок, указал репозиторий, выбрал самую новую ветку(да ССЗБ) и...во время установки один пакет не нашелся на сервере, после чего установщик выругался и ушел в ребут. Такой вот Ынтерпрайз.

@seeker:
seeker

блять блят блять ебучие красноглазые пидоры! в ебаном 2016 году иметь блять ncurses штатно без поддержки utf..

@Hawat:
Hawat

Вот есть у меня такая строчка в /etc/profile
if [ "`id -u`" -eq 0 ]; then
PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/opt/bin"
else
PATH="/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games:/sbin:/usr/sbin:/opt/bin"
fi
Она выставляет для пользователя удобный мне $PATH. Только вот с переходом на systemГ этот скрипт внезапно стал игнорироваться и $PATH превратился в /usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games. Беглый поиск решения не принес. Ну что за сука этот ПоттеринГ?

@Hawat:
Hawat

Передумал возвращать OS-X и теперь сижу и думаю, накатить уже привычный i3 или поддаться настольгии и вернуться к openbox...В DE не вижу смысла ибо KDE4/5 как DE не особо, а софт всеранво буду KDE-шный тянуть.

@Hawat:
Hawat

cdimage.debian.org а я плохо искал оказывается

@Hawat:
Hawat

Вообще очень бесит их политика относительно non-free ветки, могли-бы отдельные образы с ней собирать дабы тем кто ен страдает gnu головного мозга возни было меньше.

@ng358ex-2:
ng358ex-2

Вот уж не думал что эти два тэга буду вместе. В общем в jessie поломали нахуй ntfs-3g — input/output error при попытке открыть любой нтфсный том. Я, конечно, понимаю, что этот драйвер является неприоритетным в линуксе, но блядь >_< Принесли внешний хард на 4 тб, там ntfs разумеется. Пришлось временно менять в sources.list jessie на wheezy, ставить оттуда и холдить пакет. Приятным бонусом при удалении глючной версии ntfs-3g слетел и testdisk, пришлось тожа ставить из визи и холдить.

@Hawat:
Hawat

После тестирования на нетбуке все больше прихожу к мнению, что большая часть глюков не от systemd, а от попыток debian сидеть на трех стульях сразу. Что забавно, отказываться от SysV они не хотели из-за совместимости с kHurd и kFreeBSD, которые так и висят мертвым грузом и не шевелятся.

@ng358ex-2:
ng358ex-2

Неделю сидел мучался на gnome flashback пока не вспомнил про mate. Все мои настройки подтянулись, заработало переключение раскладок и прочее. Особенно бесило что слетела кастомная тема, на mate она отображается нормально.

@Hawat:
Hawat

Я уже давно пережил период тулкитофобии, но почему темы для GTK3 такое говно, особенно те что идут в комплекте с debian. Ищешь тему в сети — сверяй совместимость до 3 цифры в версии иначе может разъехаться к чертям.

@Hawat:
Hawat

Есть нетбук, на нет очень консервативный Debian 7(на столько консервативный, что даже dbus отсутствует). Установлено все самое нужное, нов серанво около 500 пакетов. ну ок пробуем обновить до Debian 8(--no-install0recommends по дефолту если что). Не вачто systemd/sysv/openrc, результат 1 ~ +200(новых) -50(устаревших).
Если ставить систему с нуля(в качестве init — openrc), то все те-же 400-500 пакетов в итоге. И так с каждым апдейтом между версиями, ну не умеет debian чистить пакетный мусор самостоятельно.

@Hawat:
Hawat

Несмотря на все нововведения установщик в debian8(в том числе текстовый) до сих пор в разы функциональней нежели Анаконда

@moury:
moury

Угробил два рабочих дня на попытки запустить Debian jessie на SATA RAID (dmraid).
Зацепить swap-раздел так и не удалось. Скачанные из интернета образцы dmraid.service не помогли.
Сегодня перешёл на systemV и systemd снёс.
Очень неприятно: во-первых, на этой машинке был бы полезен systemd, во-вторых, сейчас отказаться от systemd можно не во всех дистрибутивах :(

@stanislavv:
stanislavv

bugs.debian.org — Ensure users report bugs in BTS and not to upstream directly

@OCTAGRAM:
OCTAGRAM

Да ты запарил скачивать!
octagram@screwdriver:~$ sudo apt-get remove libreoffice-base libreoffice-base-core
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Будут установлены следующие дополнительные пакеты:
abiword abiword-common abiword-plugin-grammar abiword-plugin-mathview
gnumeric gnumeric-common libabiword-2.9 libgdome2-0 libgdome2-cpp-smart0c2a
libgoffice-0.8-8 libgoffice-0.8-8-common libgtkmathview0c2a liblink-grammar4
libloudmouth1-0 libots0 libreoffice-core libreoffice-draw
libreoffice-filter-binfilter libreoffice-gnome libreoffice-gtk
libreoffice-impress libreoffice-math libwv-1.2-4
link-grammar-dictionaries-en poppler-utils python-uno
Предлагаемые пакеты:
gnumeric-doc gnumeric-plugins-extra epiphany-browser ttf-liberation
ttf-mscorefonts-installer
Пакеты, которые будут УДАЛЕНЫ:
gnome libreoffice-base libreoffice-base-core libreoffice-calc
libreoffice-evolution libreoffice-help-en-us libreoffice-writer
НОВЫЕ пакеты, которые будут установлены:
abiword abiword-common abiword-plugin-grammar abiword-plugin-mathview
gnumeric gnumeric-common libabiword-2.9 libgdome2-0 libgdome2-cpp-smart0c2a
libgoffice-0.8-8 libgoffice-0.8-8-common libgtkmathview0c2a liblink-grammar4
libloudmouth1-0 libots0 libwv-1.2-4 link-grammar-dictionaries-en
poppler-utils
Пакеты, которые будут обновлены:
libreoffice-core libreoffice-draw libreoffice-filter-binfilter
libreoffice-gnome libreoffice-gtk libreoffice-impress libreoffice-math
python-uno
обновлено 8, установлено 18 новых пакетов, для удаления отмечено 7 пакетов, и 103 пакетов не обновлено.
Необходимо скачать 59,5 MБ архивов.
После данной операции, объём занятого дискового пространства уменьшится на 25,2 MB.
Хотите продолжить [Д/н]?

@kunsun:
kunsun

почему в репах всегда лежит жуткое старье, причем ладно бы просто старье с патчами но оно же с багами. в чем смысл?

@Turbid:
Turbid

где посмотреть с какими клюючами делали ./configure для определенного пакета?

@max630:
max630

iceweasel RIP bugs.debian.org

Это совпало с закручиванием гаек в ff: обязательная подписка для екстеншенов, начало http deprecation. Впрочем, удивляться не приходится — как я понял, поддержкой iceweasel занимался сотрудник mozilla, и вообще это было не для того чтобы реально независимую разработку вести, а чисто по бюрократическим соображениям типа бекпорта секурити фиксов.

(интересно, а в линуксовом firefox тоже надо будет клянчить девелоперскую сборку для запуска своих экстеншенов? ещё и небось аптом её нельзя будет поставить)

@L29Ah:
L29Ah

wiki.debian.org
$5500 за пизду

@L29Ah:
L29Ah

Хочу запихать apt-get update && apt-get dist-upgrade в крон шоб выполнялось пару раз в день. Норм?

@Turbid:
Turbid

Debian testing зачем-то хочет мне в систему притащить bind9:
$ aptitude why bind9
p heimdal-clients Предоставляют ftp
p heimdal-clients Зависит krb5-config
p krb5-config Зависит bind9-host
p bind9-host Зависит libisccfg140 (= 1:9.10.3.dfsg.P2-3)
p A libisccfg140 Зависит bind9
turbid@pc:~$ aptitude why bind9-host
i host Зависит bind9-host

@zoonman:
zoonman

Недавно обновился с 1.6 на 1.8 и все пыхорелейтед поломалось. Но легким движением руки брюки вида fastcgi_param были заменены на fastcgi.conf и оно ожило.

@Monstreek:
Monstreek

умудрилась поломать зависимости с libc6). Почему-то его смутило наличие второй архитектуры в системе. Снесла не особенно нужную вторую, вроде починила

@Greevous:
Greevous

Установил Debian 8.2 с крыской (взял с оф.сайта CD-образ). Не могу родить интернет: есть на панельке nm-applet, но модема он "не видит" т.к. при установке системы не ставится usb_modeswitch :(
Ну как так?

@segfault:
segfault

askubuntu.com
Редирекчу вопрос всезнающему. Может тут кто-нибудь в курсе, как вообще детектить такие вот падляны в деб-подобных, как держать список marked manual пакетов минимальным (аналог world файла в генте)?
Просто получается, что я могу поставить пакет, привести систему в нерабочее состояние, а просто так взять и почистить список marked manual пакетов не получится, ибо он уже засран не пойми чем. Как вы вообще там живете (без BTRFS), дебианщики?

@tzirechnoy:
tzirechnoy

На пятый год воспоминаний о крутости E14 до меня дошло, что копия должна сохраниться в архивах дебиана. Блин, и правда сохранилась! Правда, с единственной темой. И по-моему, эта тема не была моей любимой. Но, чёрт побери, насколько всё-таки этот E круче, чем та порнография, которую мы видим в e17 и далее.

@Evtomax:
Evtomax

Ну вот какого хрена неюзабельное KDE5 уже в Debian sid? Оно мне при обновлении снесло обжитое KDE4. Вообще надо всякие KDE5 и GNOME3 считать принципиально новыми отдельными DE, чем они по факту и являются. И давать возможность устанавливать KDE3, KDE4, KDE5, GNOME2, GNOME3 одновременно.

@ng358ex-2:
ng358ex-2

Сделал наконец свою задумку. Есть флешка, разбитая на два раздела. Первый, на котором установлен загрузчик grub4dos, содержит в себе загрузочные образы, всякие минилинуксы, hirens, plop boot manager и njve gjlj,yjt. На втором, с файловой системой ex2 (чтобы флешка от журналов не сдохла) установлен полновесный дебиан. Первая проблема была именно в загрузке его через grub4dos. Вторая — как грузить с разных компов, с разным количеством дисков. Решение обеих проблем в таком вот меню

title Debian Jessie
find --set-root uuid () UUID флешки
kernel /vmlinuz root=/dev/disk/by-uuid/UUID флешки
initrd /initrd.img

Заодно решил проблему с класной утилитой rescatux. Ну не хотелось мне грузить 300-метровый изошник ради 2 мегабайт самой програмы. Выдернул, закинул в свой дебиан. Для того чтобы заработало надо сделать apt-get install python-sip python-qt4 и подправить пути в rescapp.py

@ivan:
ivan

Вот, думаю, на свой старенький ноутбук (года примерно 2008) что поставить: Ubuntu Mate или Debian Mate? Софт использую обычный, что в репах и там, и там есть. Тут разве что принципиально, идеологически выбрать надо...

@ng358ex-2:
ng358ex-2

Я сижу на дебиане ещё с etch, но никогда такого факапа не случалось. Обновлял десктопы и сервера, всё было норм. Но пришёл злоебучий системд и мой домашний десктоп после обновления грузится только в rescue mode. Снёс это говно, поставил sysvinit. Стало грузиться, но из wm работают только в lxde и fluxbox. Но я уже привык к гному дома, поэтому раскатал копию визи, сделанную до обновления. При этом почему-то слетел граб, сегодня вечером буду лечить. Пиздец. Поиграл, сука, в pillars of eternity.

@xorkrus:
xorkrus

А в линуксах вот уж лет за 8 нихрена не изменилось...