to post messages and comments.

@Balancer:

Пилю драйвер для Vanilla forum, чтобы, наконец, соединить, хотя бы начерно, несколько рабочих форумов.

Наткнулся на концептуальную проблему. Чувствовал, что с ней будет что-то не так и раньше, но сейчас упёрся лбом.

В Vanilla-форуме сделано не как у многих других, где первое сообщение топика является обычным сообщением-постингом, как и ответы. Тут текст первого поста хранится прямо в записи топика. И поэтому нельзя идентифицировать стартовое сообщение по post_id, оно определяется по topic_id.

Соответственно, если топики режутся/переносятся, то первое сообщение то конвертируется из топика в постинг, то из постинга в топик.

В результате нельзя гарантировать сохранность ID такого сообщения :-/

То есть, я могу передать в Infonesy UUID такого поста равным UUID топика. И, наверное, пока так и придётся сделать. Но тогда, при операциях с топиками Vanilla, этот UUID может потеряться. Или будет указывать уже на другое сообщение.

Конечно, ещё есть вариант хранить в БД отдельные UUID и модифицировать их при операциях форума, но это многократно усложняет работу и требует вмешательства в код чужих плагинов (split/merge топиков).

Сложный, блин, случай :-/

@Balancer:

То ли моя nVidia 9800GT начала дохнуть, то ли просто перегревается и надо почистить, но комп стал зависать с характерными артефактами. Разбираться пока некогда, надо поработать, так что просто тупо выдернул и воткнул монитор во встроенный Intel (Z77 + i7). Ещё подумал, мол, придётся пока посидеть на одном мониторе. Однако, догадался воткнуть второй (DVI + VGA) — и сразу завелось. Под Ubuntu всё пошло «из коробки», всё заметно плавнее, чем было на nVidia... И всё равно не достигает и малой доли той плавности, что была сто лет назад во времени XGL или Beryl на Radeon HD2600. Вот реально было приятно сидеть с такой плавностью. Beryl даже на древней nVidia 4200 был плавнее, чем любые сегодняшние решения. Куда всё ушло, блин? :-/

И, вообще, смотрю на старую запись 2008-го года и снова убеждаюсь, что золотой век Linux закончился где-то в те времена...

youtube.com

@mrtron:

Как настроить новый принтер в linux? Почти как русская народная игрушка — матрёшка. Сперва надо конечно слазить в интернет и посмотреть на официальнос сайте ppd файл. Выяснить, что дров нет. Слазить на европейский сайт производителя и выяснить дрова есть под макось. Скачать дрова под макось. В формате .dmg конечно. Подмонтировать его просто так не получается. Сперва надо поставить p7zip-full и разархивировать этот образ. Потом надо один из 4 получившихся файлов смонтировать — mount -t hfsp -o loop '/home/mr_tron/hfs' /mnt/temp/. Потом надо в директории /mnt/temp/Kyocera\ OS\ X\ 10.5+\ build\ 2012.04.04.mpkg/Contents/Packages/Kyocera\ OS\ X\ subinstaller.mpkg/Contents/Packages/FS1040GDI.pkg/Contents/ найти файл Archive.pax.gz и распаковать его. Но! получившийся файл сам суть архив и его надо тоже распаковать. для этого надо поставить pax. Ура. Внутри обнаруживаются ppd файлы, но выясняется, что они юзают какие-то фильтры, которые тоже идут в комплекте с инсталятором и без них не работает.
Потом надо конечно постараться подобрать фильтры из имеющихся в линукс. Полагаться следует на интуицию и обрывки гугла. Потом надо случайно наткнуться на сайте какого-то сраного магазина на комментарий какого-то линуксойда, который купил именно этот принтер и таки завёл его в линукс. оказывается в коробке лежит второй диск на котором есть дрова не только под винду но и под линукс.

@zweipluse:

Не забыть скачать драйвера для диалап модема!

@Balancer:

img23.imageshack.us
Нормально так. 128Мб на звуковые драйвера :D И это при том, что оно до сих пор и 5% от умений ALSA не тянет. Ни тебе развести 2.0 в 5.1 программно, ни несколько источников сигнала записи смикшировать...

@DJm00n:

Раньше я думал, что то в Линуксе с драйверами видео пиздец...теперь я убедился на работе — что и на Шиндовс тоже самое — видеокарта NVIDIA GeForce 7300 GT — второй экран гаснет каждые полчаса, на динамичном видео горизонтальные полосы, время от времени виснет наглухо.... пиздец. он повсюду пиздец.
ЗЫ: Шиндовс 7 х64, лицензионный, ставил недавно, симптомы с самой установки.

@Balancer:

Блин, ну и что делать? Драйверов под мой Canon iP4000 под Windows x64 нету в природе. 32-х битные драйвера не подходят:
i.imgur.com
Почему, блин, под Linux просто втыкаешь принтер и работаешь с ним, а с Windows... ну да, придётся теперь для печати перегружаться в Linux... :)

@Gem:

Хорошая подборка wikidrivers.com

@artru:

Два отличных сборника драйверов для всех ОС Windows, а так же для всех принтеров. Удобно носить с собой)) artsjournal.ru Качаем с торрента

@SKEW:

Блин, теперь даже не обновится, fglrx не любит xorg сервер старше 1.9.* :-( Опять на свободные что ли перейти...

@SKEW:

Сделал дома так, чтобы звук одновременно выходил и на наушники и на колонки, под линухом всё оказалось просто, включил 4 канальный режим и радовался жизни. Винда же как обычно показала себя с "хорошей" стороны, стандартные драйвера для sb live 5.1 от виндовс поддерживали только стерео режим, поддержка от креатива для данной звуковой карты тоже закончилась, прищлось ставить дрова от KX, поставил, и только после этого смог с удовольствием перенаправить вывод саббуфера на наушники, никаким другим образом работать не хотело, включение 5.1 позволяло получать звук только на одном из наушников. В общем, теперь я счастлив :-) Можно выключить колонки, и слушать через наушники, а можно выключить звук в наушниках, и включить колонки. Заняло это у меня 2 часа, 15 минут на линухе, и полтора часа на винде с перерывом на чай.

@AlexVK:

Проблема с разрешением экрана, проявившаяся после обновления с F13 до F14 оказалась не проблемой дистрибутива, как таковой. Проявлялась она так: настройка в xorg.conf не работала. После перезагрузки разрешение выставлялось автоматически. Что было мне не удобно — приходилось выставлять руками. Попытки задать режим в xorg.conf результата особого не дали.
Выставить разрешение я пробовал через SubSection "Display", через явное указание режима — "Modes". Как выясняется, это с новыми драйверами nvidia и не работает. Возможно это проблема XOrg-а, я не выяснял. Что интересно, всё стало нормально после выставления Option "metamodes" и далее нужный мне режим. После этого всё стало нормально.
Данная опция выставлялась в утилите конфигурирования nvidia, которая поставляется с драйвером. Что и наводит на мысль что именно в драйверах nvidia источник проблем: сменилась опция и об этом нет ни слова в документации. Попытки выставить опции "по-старинке" (как уже указал) результата не дали, нагуглить подобные проблемы мне также не удалось. Так что метод проб и ошибок всё ещё в силе.

@Sandrem:

Глюк, описанный в #895583, исчез после установки новых драйверов видеокарты.

@skobkin-ru:

Вопрос к линуксоидам: как мне узнать на каком из драйверов видео работают иксы сейчас?

@derFeniX:

Хотел перейти на открый драйвер nauveau, но без 3D ускорения я в свой любимый Sauerbraten не поиграю. обидно.