to post messages and comments.

2 таблетки аспирина на 100мл воды, замочить вещь на полчаса: от следов дезодоранта.
Кетчуп, на несколько минут, почистить потом зубной щёткой — для серебряных украшений.

Печать из 1С идет на принтер по умолчанию. При смене принтера продолжает посылать на прежний.
Regedit -> HKEY_CURRENT_USER -> Software -> 1C -> 1Cv7 -> 7.7 -> база -> Config -> Moxel
Удалить Moxel нафиг и перезапустить программу.

ЭлементыФормы.Результат.Очистить();

//Определение Макета компоновки
КомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных;
МакетКомпоновки = КомпоновщикМакета.Выполнить(ОтчетОбъект.СхемаКомпоновкиДанных, ОтчетОбъект.КомпоновщикНастроек.Настройки, ДанныеРасшифровки);

////Установка параметров
//МакетКомпоновки.ЗначенияПараметров.Организация.Значение = ЭлементыФормы.Организация.Значение;
//МакетКомпоновки.ЗначенияПараметров.НачПериода.Значение = НачалоМесяца(Период);
//МакетКомпоновки.ЗначенияПараметров.КонПериода.Значение = КонецМесяца(Период2);
//
//МакетКомпоновки.ЗначенияПараметров.НачПериодаРегистратор.Значение = НачалоМесяца(Период);
//МакетКомпоновки.ЗначенияПараметров.КонПериодаРегистратор.Значение = КонецМесяца(Период1);
//
//Определение Процессора компоновки
ПроцессорКомпоновки = Новый ПроцессорКомпоновкиДанных;
ПроцессорКомпоновки.Инициализировать(МакетКомпоновки);

//Определение Процессора вывода
ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
ПроцессорВывода.УстановитьДокумент(ЭлементыФормы.Результат);


//Организация = ЭлементыФормы.Организация.Значение;

//Получение доп макета для шапки и подвала
Макет = ОтчетОбъект.ПолучитьМакет("Макет");

//Вывод шапки
Область = Макет.ПолучитьОбласть("Заголовок");
//Область.Параметры.ДатаОтчета = Формат(ТекущаяДата(), "ДФ=dd.MM.yyyy");
//Область.Параметры.Организация = организация;
//Область.Параметры.Месяц = Формат(Период, "ДФ='MMММ yyyy'");
ЭлементыФормы.Результат.Вывести(Область);

//Вывод таблицы
ПроцессорВывода.Вывести(процессорКомпоновки);

Эффективно промывание носа раствором соли с йодом: добавьте в 1 стакан кипяченой воды 7 — 10 капель йода и половину или одну чайную ложку соли.

Глобальный модуль код:
Перем Эдди Экспорт;

Процедура ПриНачалеРаботыСистемы()
//ОткрытьФорму("Справочник.КемВод",);
Эдди=СоздатьОбъект("ADDY.ADD");
Эдди.rus();
КонецПроцедуры
//*******************************************
Функция глПоискЭлемента(Какой,Код) Экспорт
Спр=СоздатьОбъект("Справочник."+Какой);
Спр.НайтиПоКоду(Код,1);
Возврат Спр.ТекущийЭлемент();
КонецФункции
//*******************************************
Функция глПоискВСправочнике(Какой,Код) Экспорт
Спр=СоздатьОбъект("Справочник."+Какой);
Спр.НайтиПоКоду(Код);
Возврат Спр.Название;
КонецФункции
//*******************************************
Функция глПоискЭлемента1(Какой,Наименование) Экспорт
Спр=СоздатьОбъект("Справочник."+Какой);
Спр.НайтиПоНаименованию(Наименование,,1);
Возврат Спр.ТекущийЭлемент();
КонецФункции
//*******************************************
Функция глПоискКода(Какой,Наименование) Экспорт
Спр=СоздатьОбъект("Справочник."+Какой);
Спр.НайтиПоНаименованию(Наименование,,1);
Возврат Спр.Код;
КонецФункции
//*******************************************

Процедура клик()
Сотрудник = СоздатьОбъект("Справочник.КемВод");
Сотрудник.выбрать("Выбор сотрудника","Справочник.КемВод.ФормаСписка");
Если Сотрудник.выбран() = 1 тогда
фио=СокрЛП(Сотрудник.Фамилия)+" "+СокрЛП(Сотрудник.Имя)+" "+СокрЛП(Сотрудник.Отчество);
др=СокрЛП(Сотрудник.ДР);
КонецЕсли;
КонецПроцедуры

"Вот мне тут рассказывали про кота одного морпеха, который миску с едой получал один раз в день на 15 минут ровно, передвигался только по полу и не умел играть."

Удивляюсь сам себе. почти закончил первую версию усовершенствованной проги для такси. Пока версия тестовая и выполняет следующие функции: при выборе района можно выбрать улицу. Можно самому изменять километраж от одного района до другого. Можно указать цену за километр. Список районов и улиц можно дополнять путем редактирования текстового файла. Заявка принимается на определенный номер, на конкретного водителя и на определенное время. Заявку можно сохранить в текстовый файл или добавить к остальным заявкам. При сохранении заявки фиксируется время принятия заявки. пока все. Работа продолжается. В следующей версии сделаю все на основе таблиц акцеса так как в ютом больше разбираюсь, но и версия на основе мускула тоже не за горами.

заметка для себя, не читайте не парьтесь :-) Сегодня начинаю совершенствовать свою прогу для определения цен в такси. Первая и единственная функция была очень проста: выбираем район в левом столбе — начальный пункт, затем выбираем район в правом столбе — конечный пункт, и нажимаем кнопку цена. до этого цены сам вбивал.. вообщем дел много, начну со списка того, что действительно там нужно.. 1.система пользователей (права доступа и тд). 2.сохранение всех заявок. 3.разделение всего хабаровска по квадратам(районам). 4.при выборе района возможность выбрать улицу. 5.отмена оформленной заявки. 6.возврат отмененной заявки к жизни 7.список водителей(редактирование списка). 8.выход на линию и уход с линии. 9. возможность отдать заявку водителю, увеличив количество выполненых заявок для этого водителя одновременно, опустив его вниз и выделив каким либо цветом в списке вышедших на линию. 10. выводить информацию о местонахождении водителя, так же иметь возможность изменять эту инфу и выводить сообщение об уточнении местонахождения через опред. промежуток времени. 11. устанавливать время на для исполнения заявки, всяческие напоминания связанные с этим. 12.фиксация телефона, сохранение и занесение в базу. подсчет колличества вызовов с данного номера. занесение номеров в черный список. 13. система скидок (более детально, позже). 14.расчет цен по киллометражу. установка цен за киллометр. 15.вывод отчета за день. 16.создание групп клиентов. определение клиента по номеру и наоборот. 17.возможность безналичного расчета. личный счет у каждого клиента внесенного в клиентскую группу. 18.автоматизирование процесса оформления одинаковых заявок(если одинаковые заявки оформлялись с одного телефона по одному маршруту и наоборот более 10 раз) 19. личный счет у водителей (должники и т.д.), различные напоминания 20.удобный интерфейс позволяющий заполнить все за секунды.... Пока все, мозг более не работает..