to post messages and comments.

← All posts tagged FF57

Greasemonkey was rewritten almost completely from scratch, based on WebExtensions ("a new browser extension API; a cross-browser system for developing extensions"). Due to the hard deadline that Firefox 57 (which supports only the WebExtensions API) Greasemonkey 4.0 was released with several features missing. Further releases in the (near) future should add most or all of Greasemonkey's older features back.
wiki.greasespot.net

И что более важно:

A variety of compromises have been made. We've elected to make a rare backwards incompatible change.
The decision was made to only support userscripts designed to run asynchronously for performance reasons. This breaks compatibility with older scripts.
greasespot.net
ghacks.net

Теперь нужно писать
await GM.getValue("foo")
вместо
GM_getValue("foo")

Нужно будет смотреть, кто из альтернативных плагинов будет обновлять своё api.
Пока что это выглядит очень хреново. Они пожертвовали обратной совместимостью, совместимостью с остальными расширениями и совместимостью со старыми скриптами, без переходного периода ("как Mozilla с нами, так и мы с вами..."). Придётся расставлять костыли чтобы по прежнему поддерживать все основные браузеры.

Violentmonkey и Tampermonkey вроде как доступны в качестве WebExtensions и при этом совместимы со старыми скриптами. Пока что Violentmonkey должен быть лучшим выбором.