← All posts tagged Ubuntu

Валидные ключи для скармливания бубну 12.04 во время тихой установки:

debian-installer/language=ru debian-installer/country=RU console-setup/ask_detect=false debian-installer/keymap=ru keyboard-configuration/optionscode=Control+Shift

Всё, что находил в интернетах - не пашет. Минимум про переключение раскладки спрашивает.

"Canonical не исключает переход Ubuntu на rolling-обновления и искоренение не LTS-релизов".
opennet.ru

Походу у них закончились животные с прикольными названиями, а официально "а довайте запилим роллинг, штоб нанотехнологии и всё такое".

Решил сделать флэшку по хаутушке из #1875321. Столкнулся с проблемой: desktop-версия исошника грузится по конфигу из статьи "на ура", а alternate версия выдаёт "error: you need to load the kernel first". Решилось всё просто. Дело в том, что у алтьернативной версии нету установщика casper, поэтому надо всего лишь поправаить grub.cfg следующим образом:

menuentry "Xubuntu 12.04 64 bit" {
   loopback loop /iso/xubuntu-12.04-alternate-amd64.iso
   linux (loop)/install/vmlinuz iso-scan/filename=/iso/xubuntu-12.04-alternate-amd64.iso vga=normal noeject noprompt nosplash --
   initrd (loop)/install/initrd.gz
}

Тут у меня образ лежит в папке "корень-флэшки/iso/"

Не работал do-release-upgrade, выдавал что-то типа:
/usr/lib/python2.6/dist-packages/UpdateManager/Core/DistUpgradeFetcherCore.py:202: DeprecationWarning: apt_pkg.GetAcquire() is deprecated. Please see apt_pkg.Acquire() for the replacement. fetcher = apt_pkg.GetAcquire(self._progress)

Решилось просто:
aptitude clean
aptitude update
aptitude upgrade
reboot
do-release-upgrade

Да, проверять не врублены ли в гуях и консолях прокси.

ualinux.com
Знакомый кинул ссылку на тесты по знанию опенсорца.
1. Форма тормозит, так, что за 10 вопросов я успел прослушать Dogs Флойдов. Вопросы типа "какая раскладка в убунту по умолчанию" — в порядке вещей. "Сервер не отвечает, попробуйте позже" — раз 5 было. В общем наслаждайтесь.

P.S. Публичная учётка бора есть.

183577 (сохранена 2011-07-20 в 14:45)
Новость на рамблере:
"В зоопарке Душанбе поселился ранимый бегемот".
Ничего, скоро придет Депрессивных Хорек с компанией и освободят бегемота!

У меня одного возникают ассоциации с релизами бубна?

Вопрос к убунтоидам: sudo aptitude search mono-runtime mono-*.*-gac выдаёт пакеты от того самого mono, который си шарп? Просто хочу с тачек знакомых поудалять всё, что с этим связано, но там зависимостей чё-то прям дофига.

В тему #890930. После того как вы сделали снимок пакетов, то на другом компе надо их влить. Делается это коммандой dpkg --set-selections < file.txt. Но после этого пакеты нифига не установятся, а только "запомнятся". Чтобы именно установить — нужно выполнить apt-get dselect-upgrade.
Источник ubuntuforums.org

Я джва года искал русск^W номальным по белому эти 2 шага.

Проблема: при логине на бубен-недобук выводилась инфа о возможности апгрейда и ссылки на офсайт бубна 2 раза.
Чтение конфига привело к опциям
PrintLastLog и PrintMotd. Последний в свою очередь привёл к /etc/update-motd.d. Где и содержались скрипты для вывода инфы. chmod -x ./* решал проблему только на половину — инфа не выводилась вообще.
В итоге: запилены свои команды по выводу инфы (не суть важно какие, они в процессе доработки), при этом в конфиге sshd_config отключены и PrintLastLog и PrintMotd. Всё стало выводиться как надо, т.е. 1 раз.

Кароче, нужно ещё поковырять почему оно работает как я хочу, когда вроде бы не должно.