to post messages and comments.

← All posts tagged Debian

Вопрос к дебианщикам: есть неизвратный способ запускать несколько instance'ов MariaDB под Debian? Неизвратный == без создания 100500 init-скриптов и более/менее нормально вписывающийся в существующую систему debian-скриптов.

Вопрос достаточно важный, потому рекоменд приветствуется.

Привет, чят. Таки немного поигрался с pbuilder (и git-pbuilder) — хорошая штука. Но остался один вопрос: а есть способ заставить его (git-buildpackage и/или git-pbuilder) собрать пакет сразу под 2+ архитектур? И еще один вопрос: можно ли git-buildpackage заставить сделать только пакет с сырцами (.dsc/orig/patch) и остановится? тогда можно было бы пересборку возложить на другие скрипты.

Есть какие-нить советы по теме?

чят, у кого есть опыт использования Zabbix? Как оно аще, стоящая фиговина? Счас статистика работает на cacti, немного устал от последнего, думаю сменить. Вот смотрю на Zabbix.

бэкпортнул поддержку выхлопа в JSON в avprobe для wheezy/jessie. По-умолчанию продолжает использоваться старый формат (sic!), json/ini можно врубить через опцию -of (как в ветке 9.х самого libav). Пакеты будут в репе через часок, берите кому надо.

как достало на каждой машине качать Java'ские .tar.gz'шки при каждом апдейте и собирать из них deb'ки. жуец, если я буду собирать deb'ки 1 раз и класть в свой debian-реп, меня анально покарает Oracle? или все ок?

Вот выходит скоро Debian Wheezy, где в составе идет php 5.4 (с выпилеными нафиг register_globals). И есть у меня сервак на Squeeze хостящий кучу говнокода на php, требующего, в частности, эти самые глобалы. И вот встает резонный вопрос: чего делать? За портирование кода скорее всего не заплатят. Ставить костыли (эмуляцию)? Селить это говно в chroot Squeeze? Не обновлять этот рак? Не знаю даже. А что бы сделал ты?

Есть у меня сервак на Ubuntu 10.04. Есть майнтенс период (эти выхи). Есть необходимость его обновить. Есть некоторое недовольство Ubuntu. Возникла шальная идея: если "обновиться" не 10.04 -> 12.04, а 12.04 -> Debian Wheezy? У кого-то есть опыт?

Да, переустанавливать систему полностью не подходит категорически, нет физ. доступа к серву.

Собрал под Sid версию 0.11 xmonad'а. Попутно пришлось обновить libghc-x11-dev и libghc-x11-xft-dev. Так что если чтот другое сломается — репорты велькам.

Брать, как обычно, на packages.gnolltech.org Если есть заинтересованые в сборке под другие версии деба и/или убунту — пишите, буду собирать по мере возможности.

жуец, хелп! debian sid.

[email protected]:~$ sudo service nginx start
[....] Starting nginx: nginxnginx: [emerg] bind() to [::]:80 failed (98: Address already in use)
nginx: [emerg] bind() to [::]:80 failed (98: Address already in use)
nginx: [emerg] bind() to [::]:80 failed (98: Address already in use)
nginx: [emerg] bind() to [::]:80 failed (98: Address already in use)
nginx: [emerg] bind() to [::]:80 failed (98: Address already in use)
nginx: [emerg] still could not bind()

при этом:
[email protected]:~$ sudo netstat -ln | grep ':80'
tcp 0 0 0.0.0.0:8010 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:8084 0.0.0.0:* LISTEN

чезанах? есть теории что это может быть?

А, совсем забыл сказать, относительно свежий (1.0.57.0-2, из sid'а) sbcl собран под squeeze. Чуть-чуть позже, надеюсь, руки дойдут и до действительно свежего (1.1.2), но пока — упс.

Брать как обычно в packages.gnolltech.org.

Обнаружил что из Debian'а выкинули пакет dcc (http://www.rhyolite.com/dcc/). Может у кого завалялись сорцы старых пакетов dcc? Неохота прост ручками перепакетировать.

ЗЫ: Борцуны за лиц. чистоту все-таки упоротые.