После обвновления еще и выяснилось, что QuakeLive Plugin not compatible with Firefox 4.0, что не могло меня не расстроить. Оказалось все это неправда и единственное что нужно сделать, чтобы плагин стал вновь compatible это изменить параметр em:maxVersion в install.rdf. Итого:
1. Выключаем firefox.
2. Идем в /home/user/.mozilla/firefox/%profilename%/extensions/quakeliveplugin@idsoftware.com
3. Правим install.rdf (меняем "<em:maxVersion>3.6.</em:maxVersion>" на "<em:maxVersion>4.</em:maxVersion>"
4. Запускам firefox и включаем плагин.

Пойду в instagib побегаю =)