← All posts tagged файлы

У жены в который раз загадочным образом пропадают открытые документы. Вот работает, вроде, сохраняет по Ctrl-S, потом однажды пытается открыть — фигушки. «[i]К сожалению, файл не найден. Возможно, он был перемещен, переименован или удален[/i]».

И с концами. Много часов работы коту под хвост. В периодическом бэкапе, что характерно, его тоже нет. Антивирусов нет (кроме встроенного виндового), Win 10, Word... не помню, какой-то из последних. Всё лицензионное.

Есть идеи, что это может быть и как с этим бороться (кроме отказа от Ворда)?

У Syncthing просто опа какая-то с юзабилити. Мало того, что вместо простых и удобных ключей в BTSync 1.x, тут используется связывание машин (что делает в принципе невозможным открытое коллективное использование Syncthing), так ещё и кошмар с конфигурированием. На всех машинах нужно прямо указывать, каким машинам раздавать каталоги. Когда число активных машин переваливает хотя бы за 5 штук, начинается просто жесть. Плюс к этому нужно перезагружать демон на каждый чих. Поменял настройки в одном каталоге, лезешь менять второй без перезагрузки — изменения в первом теряются... Сижу уже час, как идиот, настраиваю, кому что откуда и куда раздавать.

Плюс к этому совершенно невменяемые сообщения об ошибках, если что-то идёт не так...

BTSync 1.4 был по сравнению со всем этим просто эталоном...

В который раз натыкаюсь на потерю данных в файле. В фотке. Случаи единичные на многие десятки тысяч фото, но нет-нет, а наткнёшься на фотку, отображаемую лишь до половины, например. Размер тот же, нулей внутри не видно, таймстамп прежний. exiftool возвращает корректные данные. Но если сравнить с бэкапом — md5 файла отличается. Можно бы было винить железо, но это уже третья машина с таким поведением. Было подозрение на xfs, но сейчас случай с ext4. Натыкался на такую потерю данных при переполнении раздела с ext4 при копировании (на уже скопировавшихся файлах), но сейчас копирования нет, на разделе свободно 96Гб из 690Гб. Такие же проблемы иногда всплывают в видеоколлекции. Только там обнаружить сложнее, при просмотре столь короткий сбой в глаза не бросается, а вот при пересчёте хеша торрента, нет-нет, да попадётся раз в несколько месяцев «закачано на 99.8%». За секунды докачивается до 100%, но такое дело есть. Единственное, что объединяет все эти случаи — Gentoo. Но ситуация повторяется регулярно в течении многих лет (не меньше 10), за это время и ядер сколько сменилось, и настройки компиляции... А вот на ntfs/windows многие файлы лежать ещё с середины 1990-х гг., пережив десятки копирований, начиная с винчестеров по 133..270Мб... К сожалению, по той же Ubuntu такой статистики нет, все её инсталляции у меня «временные», основные архивы или в ntfs/windows, или ext4/xfs/gentoo.

Есть мысли, что это может быть? А сами вы с таким сталкивались? На всякий случай уточню, что речь о единичных потерях на многие сотни гигабайт за много лет, железо разное, файловые системы две разные, ядра разные...